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Foreword
In	the	short	but	crowded	history	of	consumer	technology,	only	two	products	ever	became
so	common,	influential,	and	powerful	that	their	names	become	verbs.

Google	is	one.

Photoshop	is	the	other.

(“Did	you	Google	that	guy	who	asked	you	out?”	“Yeah	—	he’s	crazy.	He	Photoshopped
his	last	girlfriend	out	of	all	his	pictures!”)

It’s	safe	to	say	that	these	days,	not	a	single	photograph	gets	published,	in	print	or	online,
without	having	been	processed	in	Photoshop	first.	It’s	usually	perfectly	innocent	stuff:	a
little	color	adjustment,	contrast	boosting,	or	cropping.

But	not	always.	Sometimes,	the	editing	actually	changes	the	photo	so	that	it	no	longer
represents	the	original,	and	all	kinds	of	ethical	questions	arise.	Remember	when	TV	Guide
Photoshopped	Oprah’s	head	onto	Ann-Margaret’s	body?	When	Time	magazine	darkened
O.J.	Simpson’s	skin	to	make	him	look	more	menacing	on	the	cover?	Or	when	National
Geographic	moved	two	of	the	pyramids	closer	together	to	improve	the	composition?

Well,	you	get	the	point:	Thanks	to	Photoshop,	photography	is	no	longer	a	reliable	record
of	reality.	Photoshop	is	magic.

And	now,	all	that	magic	is	in	your	hands.	Use	it	wisely.

Trouble	is,	Photoshop	is	a	monster.	It’s	huge.	Just	opening	it	is	like	watching	a	slumbering
beast	heave	into	consciousness.	Dudes,	Photoshop	has	over	500	menu	commands.

In	short,	installing	Photoshop	is	like	being	told	that	you’ve	just	won	a	747	jumbo	jet.	You
sit	down	in	the	cockpit	and	survey	the	endless	panels	of	controls	and	switches.	Now	what?

You	don’t	even	get	a	printed	manual.

If	there	were	ever	a	piece	of	software	that	needed	the	Missing	Manual	treatment,	it	was
Photoshop.

The	beast	has	been	tamed	at	last	by	its	new	master,	Lesa	Snider:	a	natural-born	Missing
Manual	author	with	Photoshop	credentials	as	long	as	your	arm.

She	had	worked	on	Missing	Manuals,	side	by	side	with	me	in	my	office,	for	four	years,	in
all	kinds	of	editorial	and	production	capacities.	Today,	when	she’s	not	writing	the
bestselling	Photoshop	book	(you’re	reading	it),	she’s	out	in	the	real	world,	teaching
Photoshop	seminars,	writing	Photoshop	articles,	reviewing	Photoshop	for	magazines,	and
generally	serving	as	Photoshop	guru	to	the	masses.

The	Missing	Manual	mantra	runs	through	her	blood:	Make	it	clear,	make	it	entertaining,
make	it	complete	(hence	the	thickness	of	this	book).	And	above	all,	don’t	just	identify	a
feature:	Tell	us	what	it’s	for.	Tell	us	when	to	use	it.	(And	if	the	answer	is,	“You’ll	never
use	it,”	tell	us	that,	too.)

Now,	I’ll	be	the	first	to	admit	that	this	book	isn’t	for	everybody.	In	fact,	it’s	aimed
primarily	at	two	kinds	of	people:	people	who	have	never	used	Photoshop,	and	people	who



have.

But	seriously,	folks.	If	you’re	new	to	Photoshop,	you’ll	find	patient,	friendly	introductions
to	all	those	nutty	Photoshoppy	concepts	like	layers,	color	spaces,	image	resolution,	and	so
on.	And,	mercifully,	you’ll	find	a	lot	of	loving	attention	to	a	time-honored	Missing	Manual
specialty	—	tips	and	shortcuts.	As	Photoshop	pros	can	tell	you,	you	pretty	much	have	to
learn	some	of	Photoshop’s	shortcuts	or	it	will	crush	you	like	a	bug.

On	the	other	hand,	if	you	already	have	some	Photoshop	experience,	you’ll	appreciate	this
book’s	coverage	of	Photoshop	CC	2014’s	new	features:	Focus	Area,	perspective	warp,
new	blur	filters,	new	font	features,	smarter	smart	guides,	3D	printing,	and	so	on.

In	2013,	Adobe	announced	that	from	now	on,	you	must	rent	Photoshop,	monthly	or	yearly.
You	can	no	longer	buy	it	outright.	One	of	the	motivations,	Adobe	said,	was	a	desire	to
create	an	ever-changing,	ever-improving	Photoshop.	There	wouldn’t	be	one	megalithic
new	version	every	couple	of	years.	Instead,	little	enhancements	would	come	along	all	year
long,	added	as	soon	as	they	were	ready.

So	what	are	we	to	make	of	this	“Photoshop	CC	2014”	thing?	Are	we	back	to	yearly
megalithic	releases?	Has	Adobe	abandoned	its	Photoshop	Forever	concept?

Yes	and	no.	The	company	still	plans	to	update	Photoshop	all	year	long.	But	it	also	plans	to
create	the	periodic	“milestone”	edition	of	Photoshop,	a	breather,	a	catch-up	version	that
rolls	in	all	the	little	changes	(and	a	few	more)	since	the	last	one.	In	part,	this	idea	is	a
crumb	thrown	to	people	who	write	(and	buy)	books	about	Photoshop;	nobody	would	be
served	well	if	Photoshop	were	a	shape-shifting	target	forever.

In	any	case,	get	psyched.	You	now	have	both	the	most	famous,	powerful,	magical	piece	of
software	on	earth	and	a	900+-page	treasure	map	to	help	you	find	your	way.

The	only	missing	ingredients	are	time,	some	photos	to	work	on,	and	a	little	good	taste.
You’ll	have	to	supply	those	yourself.

Good	luck!

—	David	Pogue

David	Pogue	is	the	founder	and	anchor	columnist	for	YahooTech.com,	having	been
groomed	for	the	position	by	13	years	as	the	tech	columnist	for	the	New	York	Times.	He’s
an	Emmy-winning	TV	correspondent	(CBS	News	and	NOVA	on	PBS),	a	Scientific
American	columnist,	and	the	creator	of	the	Missing	Manual	series.
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Introduction
Congratulations	on	buying	one	of	the	most	complicated	pieces	of	software	ever	created!
Fortunately,	it’s	also	one	of	the	most	rewarding.	No	other	program	on	the	market	lets	you
massage,	beautify,	and	transform	images	like	Photoshop.	It’s	so	popular	that	people	use	its
name	as	a	verb:	“Dude,	you	Photoshopped	the	heck	out	of	him!”	You’d	be	hard-pressed	to
find	a	published	image	that	hasn’t	spent	some	quality	time	in	this	program,	and	those	that
didn’t	probably	should	have.

The	bad	news	is	that	it’s	a	tough	program	to	learn;	you	won’t	become	a	Photoshop	guru
overnight.	Luckily,	you	hold	in	your	hot	little	hands	a	book	that	covers	the	program	from	a
practical	standpoint,	so	you’ll	learn	the	kinds	of	techniques	you	can	use	every	day.	It’s
written	in	plain	English	for	normal	people,	so	you	don’t	have	to	be	any	kind	of	expert	to
understand	it.	You’ll	also	learn	just	enough	theory	(where	appropriate)	to	help	you
understand	why	you’re	doing	what	you’re	doing.

NOTE

Prior	to	Photoshop	CC,	Adobe	offered	two	versions	of	the	program:	Photoshop	Standard	and	Photoshop	Extended,
which	included	extra	features	such	as	3D	tools.	But	they	combined	those	two	versions	into	Photoshop	CC,	so	you	get
all	the	features.



What’s	New	in	Photoshop	CC	2014
Adobe	has	added	some	incredibly	useful	new	features	to	Photoshop	CC	2014,	especially
where	productivity	is	concerned.	Graphic	designers	will	be	especially	pleased	with	all	the
new	features	and	timesaving	goodies,	although	there’s	also	a	lot	of	good	stuff	for
photographers,	too.

Perhaps	the	first	thing	you’ll	notice	is	that	Adobe	redesigned	most	of	the	program’s	dialog
boxes	to	accommodate	Retina	displays	(Apple’s	super-high	resolution	monitors,	called
HiDPI	on	PCs),	so	they’re	noticeably	shorter	and	wider	(they’re	also	a	darker	gray	and	the
buttons	are	square,	so	they	look	more	Windows-like	than	Mac-like	in	their	design).

Here’s	a	quick	overview	of	all	the	new	stuff	(don’t	worry	if	you	don’t	yet	understand	some
of	the	terms	used	here	—	you’ll	learn	them	as	you	read	through	this	book):

New	blur	filters.	This	version	of	Photoshop	CC	sports	two	additions	to	the	Blur
Gallery	family	of	filters	that	let	you	simulate	motion	in	a	photo	that	doesn’t	have	any
(or	that	doesn’t	have	enough).	The	Path	Blur	filter	lets	you	create	the	appearance	of
motion	along	a	path	that	you	draw	—	it	can	be	straight	or	riddled	with	curves	—	and
then	fine-tune	the	blur’s	direction,	angle,	speed,	and	even	how	much	blurring	occurs	at
the	path’s	start	and	end	points.	And	the	Spin	Blur	filter	lets	you	put	an	incredibly
realistic	spin	on	any	object	by	using	a	simple	set	of	on-image	controls.	Both	filters	let
you	customize	how	blurry	the	object	appears.
Typekit	access,	font	searches,	and	instant	font	previews.	One	of	the	great	benefits	of
having	a	subscription	to	Adobe’s	Creative	Cloud	service	(see	the	box	on	Meet	the
Creative	Cloud)	that	it	gives	you	access	to	hundreds	of	fonts	via	the	online	font	service
Typekit	(www.Typekit.com).	In	this	version	of	the	program,	you	can	get	to	these	fonts
right	from	Photoshop’s	font	family	menu	and	—	once	you	install	them	(which	is
incredibly	easy)	—	you	can	use	them	in	any	program	on	your	machine	that	sports	a
font	menu.	Also	new	in	the	realm	of	text	is	the	ability	to	search	all	your	installed	fonts
by	typing	part	of	a	font’s	name	(or	attribute)	into	the	font	family	menu.	And	when	a
type	layer	is	active,	you	can	point	to	any	font	in	the	font	family	menu	and	Photoshop
previews	your	existing	text	in	that	font,	right	there	in	your	document.
Better	smart	guides.	These	incredible	layer	alignment	helpers	are	now	turned	on
automatically,	and	now	show	you	a	lot	more	info	about	the	spacing	in	your	document.
When	you	have	the	Move	or	Path	Selection	tool	active,	you	can	⌘-click	(Ctrl-click	on
a	PC),	and	then	point	anywhere	in	your	document	to	see	distance	measurements
between	the	currently	active	layer’s	content	and	everything	else	in	the	document	(even
its	edge).	By	Option-dragging	(Alt-dragging)	an	object,	you	can	both	duplicate	that
layer	and	see	the	distance	between	the	duplicate	and	the	original	object	as	you	drag.
Sync	layer	comps	and	access	them	in	smart	objects.	Layer	comps	let	you	create
multiple	versions	of	an	image	or	design	without	having	to	duplicate	the	document.	New
in	this	version	of	the	program,	you	can	update	layer	comps	by	syncing	them	with	the
layers	you	updated	(a	big	timesaver	when	you	make	a	global	change	to	your	project),
plus	you	can	access	a	document’s	layer	comps	after	you’ve	placed	it	into	another
document	as	a	smart	object	—	without	opening	(editing)	the	smart	object.
Linked	smart	objects.	Instead	of	embedding	smart	object	content	into	your
documents,	you	can	now	link	then	to	external	content.	This	is	great	news	for	both
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designers	and	photographers	who	routinely	combine	large	files	into	a	single	document.
You	can	now	also	convert	an	embedded	smart	object	into	a	linked	one,	or	vice-versa.
The	Properties	panel,	Info	panel,	and	status	bar	can	all	display	handy	info	about	linked
smart	objects,	as	well	as	help	you	fix	any	broken	links	(caused	by	renaming	or	moving
the	linked	file	on	your	hard	drive)	and	update	any	content	that	you	changed	while	the
Photoshop	document	that	contains	it	was	closed.	Finally,	the	new	Package	command
copies	the	Photoshop	document	and	all	its	linked	content	so	you	can	easily	hand	the
whole	shebang	off	to	someone	else.
Select	in-focus	areas	with	Focus	Area.	This	new	command	summons	a	dialog	box
that	automatically	selects	the	in-focus	parts	of	an	image.	It	does	a	great	job	if	the	photo
has	a	strong	focal	point	and	a	blurry	background,	and	the	dialog	box	includes	a	couple
of	sliders	and	brushes	that	you	can	use	to	fine-tune	the	selection.	You	can	also	send	the
selection	straight	over	to	the	Refine	Edge	dialog	box	for	more	tweaking.
Better	color	blending	with	content-aware	tools.	All	of	Photoshop’s	content-aware
tools	now	work	faster	and	do	a	better	job	of	blending	colors,	especially	when	you	use
them	in	an	area	that’s	a	gradient	(think	skies,	water,	and	so	on).	These	days,	instead	of
having	adaptation	presets	for	the	Patch	and	Content-Aware	Move	tools,	you	get	a
Structure	and	a	Color	field	that	let	you	enter	precise	settings	for	more	realistic
blending.	Adobe	also	updated	the	Fill	command’s	Content-Aware	option	to	perform
better	blending,	and	it	now	includes	a	Color	Adaptation	checkbox.
Editable	scripted	patterns.	Scripted	patterns	are	a	fantastic	way	to	create	new	textures
and	backgrounds,	although	editing	the	JavaScript	that	powers	’em	was	a	real	pain.
Now,	choosing	one	of	the	eight	built-in	scripts	summons	a	dialog	box	that	lets	you
easily	customize	the	pattern’s	density,	size,	and	color	variations.	You	can	apply	scripted
patterns	to	paths,	too,	as	well	as	save	your	customizations	as	handy	presets	that	you	can
use	again	later.
Perspective	warp.	This	command	lets	you	change	the	perspective	of	an	image,	but
only	in	certain	areas	that	you	specify.	By	drawing	a	grid	atop	your	image,	you	can
warp	that	area	to	make	stuff	like	buildings	and	flat	surfaces	look	correct	(in	other
words,	straight	instead	of	angled).
Editable	masks	for	Camera	Raw’s	Graduated	and	Radial	filters.	Camera	Raw’s
Graduated	and	Radial	filters	are	perfect	for	applying	gradual	changes	to	a	photo	in	a
linear	or	circular	fashion	(respectively).	And	you	can	now	edit	the	masks	made	by	both
filters	by	using	a	brush.	(Camera	Raw	is	discussed	throughout	this	book,	but	the	bulk
of	the	coverage	is	in	Chapter	9.)
Export	web	graphics	with	Generator.	To	the	delight	of	web	designers	worldwide,	the
new	Generator	feature	lets	you	instantly	export	web	graphics	that	you’ve	designed	in
Photoshop	—	and	even	create	subfolders	to	organize	them	—	just	by	using	certain
layer	names.	You’ve	got	to	try	this	feature	to	believe	it.
3D	printing.	You	can	now	print	3D	objects	on	a	local	3D	printer	or	send	your	file	off
to	a	3D-printing	service	from	inside	Photoshop.	The	print	preview	that	you	get	is
incredible	and	even	shows	you	the	areas	Photoshop	filled	in	to	make	the	object	solid
enough	to	print.	If	you	go	the	printing-service	route,	the	preview	even	estimates	how
much	the	project	will	cost.	Chapter	21	helps	you	get	started	working	in	the	increasingly
popular	realm	of	3D.

There	are	also	tons	of	little	changes	in	Photoshop	CC	2014,	the	direct	result	of	Adobe’s



customer-feedback	initiative	called	Just	Do	It	(JDI).	Here’s	a	list:	You	can	unlock	a
background	layer	by	single-clicking	its	padlock	icon	(hooray!);	you	can	turn	the	Color
panel	into	a	Color	Picker	that’s	always	open;	you	no	longer	have	to	unlock	a	background
layer	to	add	a	vector-based	layer	mask	to	it;	you	can	create	gradients	with	a	single	color
stop;	and	the	process	for	syncing	your	settings	to	the	Creative	Cloud	is	simpler	and	now
includes	workspaces,	keyboard	shortcuts,	and	menu	customizations.	You	can	also	export
3D	color	lookup	tables	for	use	in	Adobe’s	pro-level	video	editing	apps;	and	the	Copy	CSS
command	now	understands	inner-shadow	layer	styles.	When	using	the	Liquify	filter,	you
can	pin	the	image’s	edges	down	so	they	don’t	get	warped.	The	Brushes	panel	displays	the
last	30	brushes	you	used	at	the	top	of	its	panel	for	quick	access,	and	uses	a	special
highlight	color	to	let	you	know	when	you’ve	modified	a	brush’s	settings.	There’s	also	an
Experimental	Feature	Manager	tucked	inside	Photoshop’s	preferences	that	lets	you	access
“not	yet	ready	for	prime	time”	features	that	Adobe	periodically	releases.

Unfortunately,	Adobe	removed	some	useful	panels	because	they	were	Flash	based,
including	the	Mini	Bridge,	Kuler,	and	Adobe	Exchange	panels	(though,	as	Other	Color
Scheme–Generating	Tools	explains,	you	can	download	Kuler	from	the	Adobe	Add-On
website	as	an	HTML-based	panel).	The	Oil	Paint	filter	also	went	the	way	of	the	dodo	bird
in	this	version	due	to	outdated	code	(easy	come,	easy	go!).



FREQUENTLY	ASKED	QUESTION:	MEET	THE	CREATIVE	CLOUD

Dude,	what	the	heck	happened	to	Photoshop	CS7?	What	on	earth	does	“CC”	mean?

Great	question.	After	CS6,	Adobe	decided	to	stop	shipping	boxed,	perpetually	licensed	versions	of	their	products.
These	days,	your	only	option	is	to	subscribe	to	—	and	then	download	—	the	software.

Using	a	service	called	the	Adobe	Creative	Cloud,	you	can	subscribe	on	an	annual	or	monthly	basis	to	one	or	all	of
Adobe’s	products.	For	example,	a	single-app	Creative	Cloud	subscription	for	Photoshop	CC	costs	about	$20	a	month
and	gives	you	access	to	both	Mac	and	PC	versions	of	the	program	that	you	can	install	on	up	to	two	machines	(say,	a
desktop	and	laptop).	If	you	use	two	or	more	Adobe	programs	(say,	Photoshop	and	InDesign),	it’s	cheaper	to	subscribe
to	all	of	their	products	for	about	$50	a	month	which,	as	of	this	writing,	includes	24	programs	and	services	(both	Mac
and	PC	versions)	—	including	access	to	Adobe	Typekit	and	the	ability	to	share	your	projects	via	Behance	(see	the	box
on	Sharing	Images	on	Behance).	That	said,	Adobe	offers	a	special	subscription	geared	toward	photographers	wherein
you	get	Photoshop	and	Photoshop	Lightroom	for	a	slick	$10	per	month	(visit	www.lesa.in/pslrfor10	for	details).
These	prices	may	change,	of	course,	so	check	with	Adobe	for	current	pricing.

Whichever	option	you	choose,	you	simply	subscribe,	and	then	download	the	software	to	your	machine	using	the
Creative	Cloud	application.	After	that,	your	Adobe	software	phones	home	once	a	month	via	the	Internet	to	validate
your	account;	if	Adobe	can’t	validate	your	account,	your	software	stops	working	(along	with	your	fonts).	In	other
words,	if	you	don’t	pay,	you	don’t	get	to	use	the	software	(though	there	is	a	30-day	grace	period	if,	for	whatever
reason,	your	computer	can’t	connect	to	the	Internet).

Once	you’re	a	Creative	Cloud	subscriber,	you	get	20	GB	of	storage	space,	which	you	can	use	to	host	websites	and
sync	documents	between	computers	and	tablets	(think	iPads),	and	to	back	up	documents	or	share	them	with	others
(regardless	of	whether	those	folks	have	Creative	Cloud	subscriptions).	You	also	get	the	ability	to	sync	custom	settings
to	the	Cloud	so	they’re	accessible	on	other	machines:	When	you	subscribe	to	the	Creative	Cloud	and	then	install
Photoshop,	your	Adobe	ID	appears	in	the	Photoshop	menu	(the	Edit	menu	on	a	PC)	with	a	submenu	that	contains
Upload	Settings	and	Download	Settings	commands.

You	can	also	sync	documents	to	the	Creative	Cloud	so	you	can	access	’em	on	other	computers	(home	and	work,	say).
For	example,	you	can	designate	a	folder	on	your	hard	drive,	and	then	any	items	you	put	into	it	automatically	sync	to
the	Creative	Cloud.	Subscribers	also	get	their	hands	on	new	features	as	soon	as	Adobe	rolls	’em	out;	the	Creative
Cloud	app	notifies	you	of	the	update	and	you	can	install	it	whenever	you	want.	With	larger	updates,	such	as	the
Photoshop	CC	2014	update,	you	install	a	whole	new	copy	of	the	program.	If	you	don’t	need	the	older	version,	just
delete	it	from	your	machine	folder	to	reclaim	some	hard	drive	space.	However,	if	your	workflow	depends	on	a	feature
that	was	changed	or	removed,	you	may	want	to	keep	it	around.	(To	learn	the	current	version	number	of	your	copy	of
Photoshop	CC,	choose	Help→System	Info.)

Adobe	will	continue	to	sell	and	support	Photoshop	CS6	for	a	while;	but	that’s	the	last	licensed	copy	you’ll	ever	get
(and	there’s	nothing	wrong	with	keeping	it	on	your	machine	if	you	already	own	it	—	in	fact,	it’s	a	good	idea).	Like	it
or	not,	we’re	now	in	the	era	of	rental	software.	(To	get	the	most	from	your	Creative	Cloud	subscription,	check	out
your	author’s	ebook,	Making	the	Most	of	Adobe’s	Creative	Cloud	at	www.theskinnybooks.com.)

If	you’re	in	North	America	or	the	United	Kingdom,	you	can	purchase	a	Creative	Cloud	subscription	through
Adobe.com,	Amazon.com,	or	Staples.com.	Folks	in	other	countries	should	go	through	Adobe.com.

And	that,	dear	friends,	is	why	the	program	is	now	called	Photoshop	Creative	Cloud,	a.k.a.	Photoshop	CC	2014.

http://www.lesa.in/pslrfor10
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About	This	Book
Adobe	has	pulled	together	an	amazing	amount	of	information	in	its	online	help	system
(see	online	Appendix	B,	available	from	this	book’s	Missing	CD	page	at
www.missingmanuals.com/cds),	but	despite	all	these	efforts,	it’s	geared	toward	seasoned
Photoshop	jockeys	and	assumes	a	level	of	skill	that	you	may	not	have.	The	explanations
are	very	clipped	and	to	the	point,	which	makes	it	difficult	to	get	a	real	feel	for	the	tool	or
technique	you	need	help	with.

That’s	where	this	book	comes	in.	It’s	intended	to	make	learning	Photoshop	CC	tolerable
—	and	even	enjoyable	—	by	avoiding	technical	jargon	as	much	as	possible	and	explaining
why	and	when	to	use	(or	avoid)	certain	features	of	the	program.	This	friendly,
conversational	approach	is	meant	to	appeal	to	beginners	and	seasoned	pixel	pushers	alike.

Some	of	the	tutorials	in	this	book	refer	to	files	you	can	download	from	this	book’s	Missing
CD	page	on	the	Missing	Manuals	website	(www.missingmanuals.com/cds)	so	you	can
practice	the	techniques	you’re	reading	about.	And	throughout	the	book,	you’ll	find	several
kinds	of	sidebar	articles.	The	ones	labeled	“Up	to	Speed”	help	newcomers	to	Photoshop
do	things	or	understand	concepts	that	veterans	are	probably	already	familiar	with.	Those
labeled	“Power	Users’	Clinic”	cover	more	advanced	topics	for	the	brave	of	heart.

NOTE

Photoshop	CC	functions	almost	identically	on	Mac	and	Windows	computers,	but	for	the	sake	of	consistency,	the
screenshots	in	this	book	were	all	taken	on	a	Mac.	However,	the	keyboard	shortcuts	for	the	two	operating	systems	are
different,	so	you’ll	find	both	included	here	—	Mac	shortcuts	first,	followed	by	Windows	shortcuts	in	parentheses,	like
so:	“press	⌘-A	(Ctrl+A).”	The	locations	of	a	few	folders	differ,	too;	in	those	cases,	you	get	the	directions	for	both
operating	systems.

About	the	Outline
This	hefty	book	is	divided	into	six	parts,	each	devoted	to	the	type	of	things	you’ll	do	in
Photoshop	CC:

Part	1.	Here’s	where	you’ll	learn	the	essential	skills	you	need	to	know	before	moving
forward.	Chapter	1	gives	you	the	lay	of	the	land	and	teaches	you	how	to	work	with
panels	and	make	the	Photoshop	workspace	your	own.	You’ll	also	find	out	the	many
ways	of	undoing	what	you’ve	done,	which	is	crucial	when	you’re	learning.	Chapter	2
covers	how	to	open	and	view	documents	efficiently,	and	how	to	set	up	new	documents
so	you	have	a	solid	foundation	on	which	to	build	your	masterpieces.
Chapter	3	dives	into	the	most	powerful	Photoshop	feature	of	all:	layers.	You’ll	learn
about	the	different	kinds	of	layers	and	how	to	manage	them,	the	power	of	layer	masks,
and	how	to	use	layer	styles	for	special	effects.	Chapter	4	explains	how	to	select	part	of
an	image	so	you	can	edit	just	that	area.	In	Chapter	5,	you’ll	dive	headfirst	into	the
science	of	color	as	you	explore	channels	(which	store	the	colors	that	make	up	your
images)	and	learn	how	to	use	channels	to	create	selections;	you’ll	also	pick	up	some
channel-specific	editing	tips	along	the	way.

NOTE

In	this	book,	the	word	“select”	is	used	only	to	refer	to	the	act	of	creating	selections.	In	most	other	instances,	the
word	“activate”	is	used	instead,	as	in	“activate	the	layer”	or	“activate	the	Crop	tool.”

http://www.missingmanuals.com/cds
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Part	2.	Chapter	6	starts	off	by	explaining	the	various	ways	you	can	crop	images	—	both
in	Photoshop	and	in	Camera	Raw	—	and	then	demystifies	resolution	so	you’ll
understand	how	to	resize	images	without	reducing	their	quality.	In	Chapter	7,	you’ll
learn	how	to	combine	images	in	a	variety	of	ways,	from	simple	techniques	to	more
complex	ones.	Chapter	8	covers	draining,	changing,	and	adding	color,	arming	you	with
several	techniques	for	creating	gorgeous	black-and-white	images,	delicious	duotones,
partial-color	effects,	and	more.	You’ll	also	learn	how	to	change	the	color	of	almost
anything.
Chapter	9	focuses	on	color-correcting	images,	beginning	with	auto	fixer-uppers,	and
then	moving	on	to	the	wonderfully	simple	(yet	powerful)	world	of	Camera	Raw	and	the
more	complicated	realm	of	Levels	and	Curves.	Chapter	10	is	all	about	retouching
images	to	change	reality	and	is	packed	with	practical	techniques	for	slimming	and
trimming.	This	chapter	also	covers	using	the	various	content-aware	tools	to	remove
objects	or	scoot	them	from	one	spot	to	another,	as	well	as	how	to	use	the	Puppet	Warp
command	to	move	just	your	subject’s	arms	and	legs.	Chapter	11	explains	what
sharpening	really	is,	and	covers	which	sharpening	method	to	use	when	to	make	your
images	look	especially	crisp.

UP	TO	SPEED:	WHAT	DOES	“64-BIT”	MEAN?

The	cool	phrase	in	computing	circles	for	the	past	few	years	has	been	“64-bit.”	While	that	term	may	sound	pretty
geeky,	it’s	actually	not	that	intimidating:	64-bit	programs	(a.k.a.	“applications”	or	“apps”)	simply	know	how	to
count	higher	than	32-bit	programs.

So	what	does	that	mean	in	practice?	32-bit	programs	can	open	and	work	with	files	that	are	up	to	4	gigabytes	in
size	—	which	is	huge.	But	64-bit	programs	can	open	files	that	are	way	bigger	than	that,	as	long	as	your
computer’s	operating	system	can	handle	64-bit	apps.	(Mac	OS	X	10.5	[Leopard]	and	Microsoft	Windows	Vista
[the	64-bit	version,	anyway]	and	later	are	up	to	the	task.)

64-bit	programs	can	also	make	use	of	more	memory	than	their	32-bit	counterparts,	which	is	crucial	when	you’re
working	with	big	honkin’	files.	For	example,	the	64-bit	version	of	Photoshop	lets	you	use	more	than	4	gigs	of
RAM,	which	makes	it	run	faster.	(You	can	change	how	your	machine’s	memory	is	allotted	by	tweaking
Photoshop’s	preferences	as	described	on	The	Missing	Credits–The	Missing	Credits.)

Older	versions	of	Photoshop	were	available	in	both	32-bit	and	64-bit	versions,	but	Photoshop	CC	is	available
only	in	64-bit	(even	on	Windows	computers),	which	is	great	news	if	you	work	with	large	files.	And	since	most
third-party	plug-ins	(Chapter	19)	and	filters	(Chapter	15)	now	work	in	64-bit	mode,	there’s	little	reason	to	cast	a
single	glance	backward.	That	said,	you	can	still	share	Photoshop	files	with	both	Mac	and	PC	folks,	just	like	you
always	have.

Part	3.	This	part	of	the	book	is	all	about	creativity.	Chapter	12	explains	the	many	ways
of	choosing	colors,	and	teaches	you	how	to	create	a	painting	from	scratch.	Chapter	13
focuses	on	using	the	mighty	Pen	tool	to	create	complex	illustrations	and	selections,
along	with	how	to	use	Photoshop’s	various	shape	tools.	Chapter	14	teaches	you	the
basics	of	typography,	and	then	moves	on	to	creating	and	formatting	text	in	Photoshop.
You’ll	find	out	how	to	outline,	texturize,	and	place	photos	inside	text,	among	other	fun-
yet-practical	techniques.	Chapter	15	covers	the	wide	world	of	filters,	including	how	to
use	smart	filters;	you’ll	come	away	with	at	least	one	practical	use	for	one	or	more	of
the	filters	in	every	category.
Part	4.	In	Chapter	16,	you’ll	learn	about	printing	images,	beginning	with	an	explanation
of	why	it’s	so	darn	hard	to	make	what	comes	out	of	your	printer	match	what	you	see
onscreen.	You’ll	discover	the	programs	different	color	modes	and	find	out	how	to
prepare	images	for	printing,	whether	you’re	using	an	inkjet	printer	or	a	commercial



printing	press.	Chapter	17	focuses	on	preparing	images	for	the	Web,	walks	you	through
the	various	file	formats	you	can	use,	explains	how	to	protect	your	images	online,	and
explains	how	to	export	web	graphics	using	Generator.	Rounding	out	the	chapter	is	info
on	using	the	Slice	tool	on	a	web	page	design,	and	step-by-step	instructions	for	creating
animated	GIFs.
Part	5.	This	part	is	all	about	working	smarter	and	faster.	Chapter	18	covers	actions
(which	help	you	automate	tasks	you	perform	regularly),	and	explains	how	to	create
gorgeous	watermarks.	Chapter	19	covers	installing	and	using	plug-ins	(small	programs
you	can	add	to	Photoshop),	and	recommends	some	of	the	best.	Chapter	20	teaches	you
how	to	edit	videos	in	Photoshop	and	create	stunning	video	portfolios,	Chapter	21	gets
you	started	creating	and	working	with	3D	objects	and	text,	and	Chapter	22	explains
how	to	use	Adobe	Bridge	for	some	slick	organization	and	batch-processing	tricks.
Part	Six:	Appendixes.	Appendix	A	covers	installing	(and	uninstalling)	Photoshop.
Appendix	B	offers	some	troubleshooting	tips,	explains	Photoshop’s	help	system,	and
points	you	to	resources	besides	than	this	book.	Appendix	C	gives	you	a	tour	of	the
mighty	Tools	panel.	And	Appendix	D	walks	you	through	Photoshop	CC’s	200+	menu
items.	All	the	appendixes	are	available	from	this	book’s	Missing	CD	page	at
www.missingmanuals.com/cds.

For	Photographers
If	you’re	relatively	new	to	digital-image	editing	or	you’ve	always	shot	film	and	are	taking
your	first	brave	steps	into	the	world	of	digital	cameras,	you’ll	be	amazed	at	what	you	can
do	in	Photoshop,	but	it	can	also	be	a	bit	overwhelming.	By	breaking	Photoshop	down	into
digestible	chunks	that	are	most	important	to	you,	the	learning	process	will	feel	less
daunting.	(There’s	no	sense	in	tackling	the	whole	program	when	you’ll	only	use	a	quarter
of	it	—	if	that	much.)

The	most	important	thing	to	remember	is	to	be	patient	and	try	not	to	get	frustrated.	With
time	and	practice,	you	can	master	the	bits	of	Photoshop	that	you	need	to	do	your	job
better.	And	with	the	help	of	this	book,	you’ll	conquer	everything	faster	than	you	might
think.	As	you	gain	confidence,	you	can	start	branching	out	into	other	parts	of	the	program
to	broaden	your	skills.

Here’s	a	suggested	roadmap	for	quickly	learning	the	most	useful	aspects	of	the	program:

1.	 Read	all	of	Chapters	Chapter	1	and	Chapter	2	(or	at	the	very	least	skim	them).
These	two	chapters	show	you	where	to	find	all	of	Photoshop’s	tools	and	features,
and	explain	how	the	program	is	organized.	You’ll	learn	how	to	open,	view,	and	save
images,	which	is	vital	stuff	to	know.

2.	 If	your	photos	aren’t	on	your	computer	already	—	and	you	don’t	use	Photoshop
Lightroom	—	read	Chapter	22	about	Adobe	Bridge.
Bridge	is	an	amazingly	powerful	image	organizer	and	browser	that	can	help	get	your
images	onto	your	computer.	It	takes	care	of	importing,	renaming,	and	even	backing
up	your	precious	photos.	That	said,	if	you	use	Lightroom,	you	can	skip	the	Bridge
chapter.

3.	 If	you	shoot	in	raw	format	(see	the	box	on	Raw	versus	JPEG)	and	need	to	color-
correct	your	images	in	a	hurry,	read	the	section	in	Chapter	9	on	editing	in
Camera	Raw	(Correcting	Images	in	Camera	Raw).

http://www.missingmanuals.com/cds


That	chapter	includes	a	whole	section	on	practical	editing	techniques	you	can	use	in
Camera	Raw,	and	a	quick	reference	that	points	you	to	where	you’ll	find	other
Camera-Raw	techniques	throughout	this	book.

4.	 If	you	don’t	shoot	in	raw	and	you	need	to	resize	your	images	before	editing
them,	read	Chapter	6.
That	chapter	explains	resolution	and	how	to	resize	images	without	reducing	their
quality.

5.	 Proceed	with	Chapters	Chapter	8,	Chapter	9,	and	Chapter	10	to	learn	about
color	effects,	correcting	color	and	lighting,	and	all	manner	of	retouching
(retouching	portraits,	moving	and	removing	objects,	and	so	on),	respectively.

6.	 When	you’re	ready	to	sharpen	your	images,	read	Chapter	11.
7.	 Finally,	when	you	want	to	print	your	photos,	read	the	section	on	printing	with

an	inkjet	printer	in	Chapter	16	(Printing	on	an	Inkjet	Printer).
The	chapter	walks	you	through	the	printing	process.

That’s	all	you	need	to	get	started.	When	you’re	ready	to	dive	further	into	Photoshop,	pick
back	up	at	Chapter	3,	which	covers	layers,	and	then	move	on	through	the	book	as	time
permits.

The	Very	Basics
This	book	assumes	that	you	know	how	to	use	a	computer	and	that,	to	some	extent,	you’re
an	expert	double-clicker	and	menu	opener.	If	not,	here’s	a	quick	refresher:

To	click	means	to	move	the	point	of	your	cursor	over	an	object	onscreen,	and	then	press
the	left	mouse	or	trackpad	button	once.	To	drag	means	to	click	an	object	and	then,	while
still	holding	down	the	mouse	button,	move	the	mouse	to	move	the	object.	To	double-click
means	to	press	the	left	button	twice,	quickly,	without	moving	the	cursor	between	clicks.
To	right-click	means	to	press	the	right	mouse	button	once,	which	produces	a	menu	of
special	features	called	a	shortcut	menu	(a.k.a.	contextual	menu).	If	you’re	on	a	Mac	and
have	a	mouse	with	only	one	button,	you	can	simulate	right-clicking	by	holding	down	the
Control	key	while	you	click.

Most	onscreen	controls	are	pretty	obvious,	but	you	may	not	be	familiar	with	radio	buttons:
To	choose	an	option,	you	click	one	of	these	little	empty	circles	that	are	arranged	in	a	list.

You’ll	find	tons	of	keyboard	shortcuts	throughout	this	book,	and	they’re	huge	timesavers.
If	you	see	a	sentence	like,	“Press	⌘-S	(Ctrl+S)	to	save	your	file,”	that	means	to	hold	down
the	⌘	key	(or	Ctrl	key,	if	you’re	using	a	PC),	and	then	press	the	S	key,	too;	then	let	go	of
both	keys.	(This	book	lists	Mac	keyboard	shortcuts	first,	followed	by	Windows	shortcuts
in	parentheses.)	Other	keyboard	shortcuts	are	so	complex	that	you’ll	need	to	use	multiple
fingers,	both	hands,	and	a	well-placed	elbow.	And	sometimes	you’ll	combine	keystrokes
with	clicking.	For	example,	to	⌘-click	(Ctrl-click	on	a	PC)	means	to	press	and	hold	the	⌘
(or	Ctrl)	key	and	then,	while	still	pressing	the	key,	click	your	left	mouse	button.

If	you’re	comfortable	with	basic	concepts	like	these,	you’re	ready	to	get	started	with	this
book.

About→These→Arrows
In	this	book	(and	in	all	Missing	Manuals,	for	that	matter),	you’ll	see	arrows	sprinkled



throughout	each	chapter	in	sentences	like	this:	“Choose	Filter→Blur	Gallery→Tilt-Shift.”
This	is	a	shorthand	way	of	helping	you	find	files,	folders,	and	menu	items	without	having
to	read	through	painfully	long,	boring	instructions.	For	example,	the	sentence	quoted
above	is	a	short	way	of	saying	this:	“At	the	top	of	the	Photoshop	window,	locate	the	Filter
menu.	Click	it	and,	in	the	list	that	appears,	look	for	the	Blur	Gallery	category.	Point	your
cursor	at	the	words	Blur	Gallery	(without	clicking)	and,	in	the	resulting	submenu,	click
Tilt-Shift”	(see	Figure	1).

Figure	1.	Choosing	Filter→Blur	Gallery→Tilt-Shift	takes	you	to	the	menu	item	shown	here.



About	the	Online	Resources
As	the	owner	of	a	Missing	Manual,	you’ve	got	more	than	just	a	book	to	read.	Online,
you’ll	find	example	files	so	you	can	get	some	hands-on	experience.	You	can	also
communicate	with	the	Missing	Manual	team	and	tell	us	what	you	love	(or	hate)	about	the
book.	Head	over	to	www.missingmanuals.com,	or	go	directly	to	one	of	the	following
sections.

Missing	CD
This	book	doesn’t	have	a	CD	pasted	inside	the	back	cover,	but	you’re	not	missing	out	on
anything.	Go	to	www.missingmanuals.com/cds	to	download	sample	files	and	the	book’s
appendixes.	And	so	you	don’t	wear	down	your	fingers	typing	long	web	addresses,	the
Missing	CD	page	also	offers	clickable	links	to	all	the	websites	mentioned	in	this	book.

Registration
If	you	register	this	book	at	oreilly.com,	you’ll	be	eligible	for	special	offers	—	like
discounts	on	future	editions.	Registering	takes	only	a	few	clicks.	To	get	started,	head	to
http://oreilly.com/register.

Feedback
Got	questions?	Need	more	information?	Fancy	yourself	a	book	reviewer?	On	our
Feedback	page,	you	can	get	answers	to	questions	that	come	to	you	while	reading	and	share
your	thoughts	on	this	Missing	Manual.	To	have	your	say,	go	to
www.missingmanuals.com/feedback.

Errata
In	an	effort	to	keep	this	book	as	up-to-date	and	accurate	as	possible,	each	time	we	print
more	copies,	we’ll	make	any	confirmed	corrections	you’ve	suggested.	We	also	note	such
changes	on	the	book’s	website,	so	you	can	mark	important	corrections	into	your	own	copy
of	the	book,	if	you	like.	Go	to	http://tinyurl.com/psccmm2e	to	report	an	error	or	view
existing	corrections.

Safari®	Books	Online
Safari®	Books	Online	is	an	on-demand	digital	library	that	lets	you	easily	search	over
7,500	technology	and	creative	reference	books	and	videos	to	find	the	answers	you	need
quickly.

With	a	subscription,	you	can	read	any	page	and	watch	any	video	from	our	library	online.
Read	books	on	your	cellphone	and	mobile	devices.	Access	new	titles	before	they’re
available	for	print,	and	get	exclusive	access	to	manuscripts	in	development	and	post
feedback	for	the	authors.	Copy	and	paste	code	samples,	organize	your	favorites,	download
chapters,	bookmark	key	sections,	create	notes,	print	out	pages,	and	benefit	from	tons	of
other	timesaving	features.

http://www.missingmanuals.com
http://www.missingmanuals.com/cds
http://oreilly.com/register
http://www.missingmanuals.com/feedback
http://tinyurl.com/psccmm2e
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Chapter	1.	Photoshop	CC	Guided	Tour
Photoshop	CC	is	bursting	with	fabulous	features	that’ll	help	you	edit	and	create	your	very
own	digital	masterpieces.	If	this	is	your	first	foray	into	the	world	of	Photoshop,	all	these
features	will	be	new	to	you.	If	you’re	an	experienced	pixel	pusher,	there	are	some
surprises	waiting	for	you,	too.	If	you’re	upgrading	from	Photoshop	CS5	or	earlier,	Adobe
introduced	major	changes	to	the	work	environment	back	in	CS6	—	like	a	brand-new	color
theme	—	and	while	these	changes	make	Photoshop	easier	to	use,	they	take	some	getting
used	to.

This	chapter	gives	you	a	solid	foundation	on	which	to	build	your	Photoshop	skills.	You’ll
learn	how	to	work	with	the	Application	Frame,	and	how	to	wrangle	document	windows
and	panels.	Once	you’ve	gotten	them	placed	just	right,	you’ll	learn	how	to	save	your	setup
as	a	custom	workspace.	If	you’re	a	beginner,	the	section	on	using	Undo	commands	and
history	states	will	teach	you	how	to	fix	mistakes	and	back	out	of	almost	anything	you’ve
done.	Finally,	you’ll	learn	how	to	fine-tune	Photoshop’s	behavior	through	preferences	and
built-in	tools	(called	presets)	that	let	you	personalize	your	experience	even	more.	Let’s
dive	in!



Meet	the	Application	Frame
When	you	launch	Photoshop	CC	for	the	first	time,	you’re	greeted	by	the	Application
Frame	shown	in	Figure	1-1.	This	frame	confines	all	things	Photoshop	to	a	single	resizable,
movable	window.	You	can	grab	the	whole	mess	—	documents,	panels,	and	all	—	and	drag
it	to	one	side	of	your	screen	(or	better	yet,	to	another	monitor)	so	it’s	out	of	the	way.	And
if	you	open	more	than	one	document,	they’re	displayed	in	handy	tabs	that	you	can
rearrange	by	dragging.

Chances	are,	you’ll	either	love	the	Application	Frame	or	hate	it.	If	you’re	on	a	computer
running	Windows,	you’re	used	to	programs	looking	and	behaving	this	way.	But	if	you’re
on	a	Mac	and	you’re	coming	from	an	older	version	of	Photoshop	(like	CS3),	this
arrangement	may	feel	odd;	in	that	case,	you	can	turn	off	the	frame	by	choosing
Window→Application	Frame	to	make	Photoshop	switch	to	the	floating-window	view
used	in	older	versions	of	the	program.	(PC	folks	are	stuck	with	the	frame.)

NOTE

In	Photoshop	CC,	you’ll	spot	a	special	button	at	the	bottom	of	each	document	window	that	looks	like	a	rectangle	with
a	curved	arrow	inside	it.	Clicking	it	uploads	the	current	document	to	Adobe’s	portfolio-sharing	community	site
Behance	—	a	great	way	to	get	critical	feedback	on	projects.	To	learn	more	about	Behance,	see	the	box	on	Sharing
Images	on	Behance	and	check	out	your	author’s	ebook	“The	Skinny	on	Behance”	at	www.theskinnybooks.com.

Figure	1-1.	You	can	open	several	images	at	once;	just	click	a	document’s	tab	to	summon	it	for	editing.	Photoshop
stores	the	tools	and	adjustments	you’ll	use	most	in	the	panels	on	the	sides	of	the	Application	Frame;	a	full

introduction	to	panels	starts	on	page	3.	(Figure	1-9	on	page	14	explains	how	to	make	your	Tools	panel	have	two
columns	like	the	one	shown	here.)

http://www.theskinnybooks.com


NOTE

Adobe	reduced	clutter	back	in	Photoshop	CS6	by	removing	the	Application	bar,	which	used	to	house	extras	like
guides,	grids,	and	rulers,	as	well	as	several	menus.	As	you	learn	in	the	next	few	pages,	those	items	are	now	sprinkled
throughout	the	Tools	panel,	the	View	menu,	and	the	Window	menu.

Also,	if	you	use	Photoshop	alongside	other	programs,	the	box	on	Hiding	vs.	Quitting	explains	how	to	get	Photoshop
out	of	the	way	without	quitting	it.

The	Almighty	Options	Bar
Lording	over	the	document	window	is	the	Options	bar	(Figure	1-2,	top),	which	lets	you
customize	the	behavior	of	nearly	every	item	in	the	Tools	panel.	This	bar	automatically
changes	to	include	settings	related	to	the	tool	you’re	currently	using.	The	Options	bar	also
includes	the	workspace	menu,	which	lets	you	change	the	way	your	Photoshop
environment	is	set	up	(you	learn	about	workspaces	on	Customizing	Your	Workspace).

Unfortunately,	the	Options	bar’s	labels	are	fairly	cryptic,	so	it	can	be	hard	to	figure	out
what	the	heck	all	those	settings	do.	Luckily,	you	can	point	your	cursor	at	any	setting	to	see
a	little	yellow	pop-up	description	called	a	tooltip	(you	don’t	need	to	click	—	just	don’t
move	your	mouse	for	a	couple	seconds).

TIP

If	the	tooltips	drive	you	crazy,	you	can	hide	’em	by	choosing	Photoshop→Preferences→Interface
(Edit→Preferences→Interface	on	a	PC)	and	turning	off	Show	Tool	Tips.

When	you	first	install	Photoshop,	the	Options	bar	is	perched	at	the	top	of	your	screen,	but
it	doesn’t	have	to	stay	there.	If	you’d	rather	put	it	somewhere	else,	grab	its	left	end	and
drag	it	wherever	you	want,	as	shown	in	Figure	1-2,	middle.	If	you	decide	to	put	it	back
later	(also	called	docking),	just	drag	it	to	the	top	of	the	screen	and,	when	you	see	a	thin
blue	line	appear	(Figure	1-2,	bottom),	release	your	mouse	button.



Figure	1-2.	Top:	The	Options	bar	is	customization	central	for	whatever	tool	you’re	currently	using.	But	it	doesn’t
have	to	live	at	the	top	of	the	screen;	you	can	undock	it	by	dragging	the	tiny	dotted	lines	circled	here.	Middle:	Once
you’ve	freed	the	Options	bar,	you	can	drag	it	anywhere	you	want	by	grabbing	the	dark	gray	bar	on	its	far	left.

Bottom:	To	redock	the	Options	bar,	drag	it	to	the	top	of	your	screen.	Once	you	see	a	thin	blue	line	like	the	one	visible
here,	release	your	mouse	button.

TIP

If	a	tool	seems	to	be	misbehaving,	it’s	likely	because	you	changed	one	of	the	Options	bar’s	settings	and	forgot	to
change	it	back.	These	settings	are	sticky:	Once	you	change	them,	they	stay	that	way	until	you	change	them	back.
Figure	1-17	explains	how	to	reset	a	tool	to	its	factory-fresh	settings.

NOTE

Adobe	recently	added	the	ability	to	shrink	the	Options	bar	to	a	narrower	version,	which	is	handy	if	you’ve	got	a	small
screen.	Skip	to	Changing	Photoshop’s	Appearance	for	the	scoop.

Swapping	Screen	Modes
Photoshop	includes	three	different	screen	modes	for	your	document-viewing	pleasure.
Depending	on	what	you’re	doing,	one	will	suit	you	better	than	the	others.	For	example,
you	can	make	an	image	take	up	your	whole	screen	(with	or	without	the	menus	and
Options	bar),	hide	Photoshop’s	panels,	and	so	on	(see	Figure	1-3).	To	give	each	mode	a
spin,	you	first	need	to	open	an	image:	Choose	File→Open,	navigate	to	where	an	image
lives,	and	then	click	Open.



TIP

You	can	free	up	precious	screen	real	estate	by	pressing	the	Tab	key	to	hide	the	Options	bar	and	panels	(pressing	Shift-
Tab	hides	all	the	panels	except	the	Tools	panel).	This	trick	is	a	great	way	to	get	rid	of	distractions	when	you’re	editing
images,	especially	if	you	have	a	small	monitor.	To	bring	the	panels	back,	press	Tab	again	or	mouse	over	to	the	edge	of
the	Photoshop	window	where	the	panels	should	be;	when	you	move	your	cursor	away	from	the	panels,	they’ll
disappear	again.

It’s	a	snap	to	jump	between	modes.	Just	press	the	F	key	repeatedly	—	unless	you’re	in	the
middle	of	cropping	an	image	or	using	the	Type	tool	(if	you	are,	you’ll	type	a	bunch	of	Fs)
—	or	use	the	Screen	Modes	menu	at	the	bottom	of	the	Tools	panel	(circled	in	Figure	1-3,
top).	These	are	your	choices:

Standard	Screen	Mode	is	the	view	you	see	when	you	launch	Photoshop	for	the	first
time.	This	mode	includes	menus,	the	Application	Frame,	the	Options	bar,	panels,	and
document	windows.	Use	this	mode	when	the	Application	Frame	is	active	and	you	need
to	scoot	the	whole	of	Photoshop	—	windows	and	all	—	around	on	your	monitor
(except	for	undocked	panels	or	free-floating	windows).
Full	Screen	Mode	With	Menu	Bar	completely	takes	over	your	screen,	puts	your
document	in	the	center	on	a	dark	gray	canvas	or	frame,	and	attaches	any	open	panels	to
the	left	and	right	edges	of	your	screen.	This	mode	is	great	for	day-to-day	editing
because	you	can	see	all	of	Photoshop’s	tools	and	menus	without	being	distracted	by	the
files	and	folders	on	your	desktop.	The	dark	gray	background	is	also	easy	on	the	eyes
and	a	great	choice	when	color-correcting	images	(a	brightly	colored	desktop	can	affect
your	color	perception).

TIP

You	can	change	Photoshop’s	canvas	color	anytime	by	Control-clicking	(right-clicking	on	a	PC)	the	canvas	itself.
From	the	shortcut	menu	that	appears,	choose	from	Default	(the	dark,	charcoal	gray	you	see	now),	Black,	Dark
Gray,	Medium	Gray,	or	Light	Gray.	If	none	of	those	colors	float	your	boat,	you	can	pick	your	own	by	choosing
Select	Custom	Color	to	open	the	Color	Picker,	which	is	explained	on	Choosing	Individual	Colors.

Full	Screen	Mode	hides	all	of	Photoshop’s	menus	and	panels,	centers	the	document	on
your	screen,	and	puts	it	on	a	black	background.	(If	you’ve	got	rulers	turned	on,	they’ll
still	appear,	though	you	can	turn	’em	off	by	pressing	⌘-R	[Ctrl+R]).	This	mode	is
great	for	displaying	and	evaluating	your	work	or	for	distraction-free	editing.	And	the
black	background	really	makes	images	pop	off	the	screen	(though	the	next	section
shows	you	how	to	change	it	to	another	color).



Figure	1-3.	The	many	faces	of	Photoshop:	Standard	Screen	Mode	(top),	Full	Screen	With	Menu	Bar	(bottom	left),	and
Full	Screen	(bottom	right).	You	can	edit	images	in	any	of	these	modes,	though	some	give	you	more	screen	real	estate
than	others.	The	Screen	Modes	menu	(circled)	lives	at	the	bottom	of	the	Tools	panel.	Figure	1-9	on	page	14	tells	you

how	to	switch	to	a	two-column	Tools	panel	like	the	one	shown	here.

Changing	Photoshop’s	Appearance
While	the	dark	gray	interface	colors	introduced	in	CS6	are	supposed	to	be	easier	on	the
eyes	and	help	you	see	the	colors	in	images	more	accurately,	you	may	disagree.	You	may
also	want	to	increase	the	size	of	the	text	labels	in	the	Options	bar	and	panels.	Fortunately,
you	can	change	several	aspects	of	the	program’s	appearance	by	choosing
Photoshop→Preferences→Interface	(Edit→Preferences→Interface	on	a	PC),	as	Figure	1-
4	shows.

The	next	section	tells	you	how	to	customize	Photoshop’s	look	and	feel	even	more	by
opening,	closing,	rearranging,	and	resizing	panels.	Read	on!



Figure	1-4.	Not	a	fan	of	the	dark	gray	color	theme?	Use	these	settings	to	pick	something	lighter	(the	light	gray
square	reverts	to	CS5’s	color	theme).	To	change	Full	Screen	Mode’s	background	color	to	something	other	than	black,
use	the	Full	Screen	drop-down	menu.	Photoshop	also	sports	a	narrow	Options	bar	(circled),	which	is	nice	for	small
screens.	If	the	text	labels	throughout	the	program	have	you	squinting,	make	’em	bigger	by	using	the	UI	Font	Size

menu	shown	here	(then	quit	and	restart	Photoshop	to	make	your	change	take	effect).

UP	TO	SPEED:	HIDING	VS.	QUITTING

If	you	need	to	do	some	work	on	your	desktop	or	in	another	program,	you	can	temporarily	hide	Photoshop,	saving	you
the	time	and	toe-tapping	of	quitting	it	and	then	restarting	it	again	later.

On	a	Mac,	press	⌘-Control-H	or	click	the	yellow	dot	at	the	top	left	of	the	Application	Frame	to	minimize	the
window	(if	you’ve	changed	your	Appearance	system	preferences	to	Graphite,	the	dot	is	gray	instead).	Your
workspace	disappears,	but	Photoshop	keeps	running	in	the	background.	To	bring	it	back	to	the	forefront,	click	its	icon
in	the	Dock.	You	can	also	make	Photoshop	temporarily	disappear	by	pressing	⌘-H;	the	first	time	you	do,	a	dialog
box	appears	asking	if	you’d	like	to	assign	that	keyboard	shortcut	to	make	it	hide	Photoshop	instead	of	hiding	text
highlighting,	guides,	and	so	on.	(To	change	it	back,	edit	your	keyboard	shortcuts	as	explained	in	the	box	on
Customizing	Keyboard	Shortcuts	and	Menus,	or	delete	Photoshop’s	preferences	as	described	in	the	first	Note	on
Note.)

On	a	PC,	you	can	minimize	(hide)	the	program	by	clicking	the	minus	button	in	Photoshop’s	upper	right;	Windows
tucks	the	program	down	into	your	taskbar.	To	get	it	back,	click	its	taskbar	icon.

If	your	machine	has	at	least	8	GB	of	memory	(RAM),	there’s	absolutely	no	downside	to	hiding	Photoshop.	However,
if	you’re	low	on	memory	and	your	machine’s	fan	is	cranking	away,	then	choose	Photoshop→Quit	Photoshop
(File→Exit	on	a	PC)	instead.



Working	with	Panels
The	right	side	of	the	Application	Frame	is	home	to	a	slew	of	small	windows	called	panels,
which	let	you	work	with	frequently	used	features	like	colors,	adjustments,	layers,	and	so
on.	You’re	free	to	organize	the	panels	however	you	like	and	position	them	anywhere	you
want.	Panels	can	be	free	floating	or	docked	(attached)	to	the	top,	bottom,	left,	or	right
sides	of	your	screen.	And	you	can	link	panels	together	into	groups,	which	you	can	then
move	around.	Each	panel	also	has	its	very	own	menu,	called	(appropriately	enough)	a
panel	menu,	located	in	its	top-right	corner;	its	icon	looks	like	four	little	lines	with	a
downward-pointing	triangle	and	is	labeled	in	Figure	1-5,	left.

Figure	1-5.	Here	you	can	see	the	difference	between	expanded	panels	(left)	and	collapsed	panels	(right).	Double-
click	a	panel’s	tab	to	collapse	it	vertically,	rolling	it	up	like	a	window	shade;	single-click	the	tab	again	to	expand	the
panel.	You	can	also	collapse	a	panel	horizontally	by	clicking	the	right-pointing	double	arrows	in	its	top	right	(circled,
right),	at	which	point	it	turns	into	a	small	button.	To	expand	one	of	these	buttons	back	into	a	panel,	just	click	the	left-

pointing	double	arrows	circled	here	(circled,	middle).

Take	a	peek	at	the	right	side	of	your	screen	and	you’ll	see	that	Photoshop	starts	you	off
with	three	docked	panel	groups	filled	with	goodies	it	thinks	you’ll	use	a	lot	(there’s	more
on	docked	panels	coming	up	shortly).	The	first	group	contains	the	Color	and	Swatches
panels;	the	second	group	contains	Adjustments	and	Styles;	and	the	third	contains	Layers,
Channels,	and	Paths.	To	work	with	a	panel,	activate	it	by	clicking	its	tab.

Panels	are	like	Silly	Putty	—	they’re	incredibly	flexible.	You	can	collapse,	expand,	move,
and	resize	them,	or	even	swap	’em	for	other	panels.	Here’s	how:

Collapse	or	expand	panels.	If	panels	are	encroaching	on	your	editing	space,	you	can
shrink	them	both	horizontally	and	vertically	so	they	look	and	behave	like	buttons.	To
collapse	a	panel	(or	panel	group)	horizontally	so	that	it	becomes	a	button	nestled
against	the	side	of	another	panel	or	the	edge	of	your	screen,	click	the	tiny	double	arrow
in	its	top-right	corner;	click	this	same	button	again	to	expand	the	panel.	To	collapse	a
panel	vertically	against	the	bottom	of	the	panel	above	it,	as	shown	in	Figure	1-5,	right,
double-click	the	panel’s	tab	or	the	empty	area	to	its	right;	single-click	the	tab	or



double-click	the	empty	area	to	roll	the	panel	back	down.	To	adjust	a	panel’s	width,
point	your	cursor	at	its	left	edge	and,	when	the	cursor	turns	into	a	double-headed	arrow,
drag	left	or	right	to	make	the	panel	bigger	or	smaller	(though	some	panels	have	a
minimum	width).
Add	and	modify	panel	groups.	You	can	open	even	more	panels	by	opening	the
Window	menu	(which	lists	all	of	Photoshop’s	panels)	and	clicking	the	name	of	the	one
you	want	to	open.	When	you	do,	Photoshop	puts	the	panel	in	a	column	to	the	left	of	the
ones	that	are	already	open	and	adds	a	tiny	button	to	its	right	that	you	can	click	to
collapse	it	both	horizontally	and	vertically	(just	click	the	same	button	again	to	expand
it).	If	the	new	panel	is	part	of	a	group,	like	the	Character	and	Paragraph	panels,	the
extra	panel	tags	along	with	it.	If	it’s	a	panel	you	expect	to	use	a	lot,	you	can	add	it	to	an
existing	panel	group	by	clicking	and	dragging	the	dotted	lines	above	its	button	into	a
blank	area	in	the	panel	group,	as	shown	in	Figure	1-6.
Undock,	redock,	and	close	panels.	From	the	factory,	Photoshop	docks	three	sets	of
panel	groups	to	the	right	side	of	your	screen	(or	Application	Frame).	But	you’re	not
stuck	with	the	panels	glued	to	this	spot;	you	can	set	them	free	by	turning	them	into
floating	panels.	To	liberate	a	panel,	grab	its	tab,	pull	it	out	of	the	group	it’s	in,	and	then
move	it	anywhere	you	want	(see	Figure	1-7).	When	you	let	go	of	your	mouse	button,
the	panel	appears	where	you	put	it	—	all	by	itself.
You	can	undock	a	whole	panel	group	in	nearly	the	same	way:	Click	an	empty	spot	in
the	group’s	tab	area	and	drag	it	out	of	the	dock.	Once	you	release	your	mouse	button,
you	can	drag	the	group	around	by	clicking	the	same	empty	spot	in	the	tab	area.	Or,	if
the	group	is	collapsed,	click	the	tiny	dotted	lines	at	the	top	of	the	group,	just	below	the
dark	gray	bar.
To	redock	the	panel	(or	panel	group),	drag	it	back	to	the	right	side	of	your	screen.	To
prevent	a	panel	from	docking	while	you’re	moving	it	around,	⌘-drag	(Ctrl-drag)	it
instead.



Figure	1-6.	Top:	When	you	open	a	new	panel,	Photoshop	adds	it	to	a	column	to	the	left	of	your	other	panels	and
gives	it	a	handy	button	that	you	can	click	to	collapse	or	expand	it,	like	the	Info	panel’s	button	circled	here.	The	tiny
dotted	line	above	each	button	is	its	handle;	click	and	drag	one	of	these	handles	to	reposition	the	panel	in	the	column,
add	the	panel	to	a	panel	group,	and	so	on.	If	the	panel	you	opened	is	related	to	another	panel	—	like	the	Brush	panel
and	the	Brush	Presets	panel	—	then	both	panels	will	open	as	a	panel	group	with	a	single	handle.	Middle:	When

you’re	dragging	a	panel	into	a	panel	group,	wait	until	you	see	a	blue	line	around	the	inside	of	the	group	before	you
release	your	mouse	button.	Here,	the	Info	panel	is	being	added	to	a	panel	group.	(You	can	see	a	faint	version	of	the
Info	panel’s	button	where	the	red	arrow	is	pointing.)	Bottom:	When	you	release	your	mouse	button,	the	new	panel
becomes	part	of	the	group.	To	rearrange	panels	within	a	group,	drag	their	tabs	(circled)	left	or	right.	If	the	blue

highlight	lines	are	hard	to	see	when	you’re	trying	to	group	or	dock	panels,	try	dragging	the	panels	more	slowly.	That
way,	when	you	drag	the	panel	into	a	group	or	dockable	area,	the	blue	highlight	hangs	around	a	little	longer	and	the

panel	becomes	momentarily	transparent.



Figure	1-7.	To	undock	a	panel	(or	panel	group),	click	the	panel’s	tab	(or	a	free	area	to	the	right	of	the	group’s	tabs),
and	then	drag	the	panel	or	group	somewhere	else	on	your	screen.	To	dock	it	again,	drag	it	to	the	right	side	of	your
screen	—	on	top	of	the	other	panels.	When	you	see	a	thin	blue	line	appear	where	you	want	the	panel	(or	group)	to

land,	release	your	mouse	button.

NOTE

The	Timeline	panel	(which	was	called	the	Animation	panel	prior	to	Photoshop	CS6)	is	docked	to	the	bottom	of	your
workspace,	which	is	a	docking	hotspot,	too.	That	said,	Photoshop	refuses	to	let	you	dock	the	Options	bar	down	there.

To	close	a	panel,	click	its	tab	and	drag	it	out	of	the	panel	group	to	a	different	area	of	your
screen	(Figure	1-7);	then	click	the	tiny	circle	in	the	panel’s	top-left	corner	(on	a	PC,	click
the	X	in	the	panel’s	top-right	corner	instead).	Don’t	worry	—	the	panel	isn’t	gone	forever;
if	you	want	to	reopen	it,	simply	choose	it	from	the	Windows	menu.

Getting	the	hang	of	undocking,	redocking,	and	arranging	panels	takes	a	little	practice
because	it’s	tough	to	control	where	the	little	rascals	land.	When	the	panel	you’re	dragging
is	about	to	join	a	docking	area	(or	a	different	panel	group),	a	thin	blue	line	appears
showing	you	where	the	panel	or	group	will	go.

Customizing	Your	Workspace
Once	you	arrange	Photoshop’s	panels	just	so,	you	can	keep	’em	that	way	by	saving	your
setup	as	a	workspace,	using	the	unlabeled	Workspace	drop-down	menu	at	the	right	end	of
the	Options	bar	(see	Figure	1-8).	Straight	from	the	factory,	this	menu	is	set	to	Essentials,
which	is	a	good	general-use	setup	that	includes	panels	that	most	people	use	regularly.	The
menu’s	other	options	are	more	specialized:	3D	is	designed	for	working	with	3D	objects
(see	Chapter	21),	Motion	is	for	video	editing,	Painting	is	for	(you	guessed	it)	painting,
Photography	is	for	working	with	photos,	and	Typography	is	for	working	with	text.	To
swap	workspaces,	simply	click	one	of	these	presets	(built-in	settings),	and	Photoshop
rearranges	your	panels	accordingly.

NOTE

Gone	in	this	version	of	Photoshop	is	the	What’s	New	workspace,	which	used	to	highlight	all	the	menu	items	that
included	new	features.	However,	all	is	not	lost:	you	can	choose	Help→What’s	New	to	visit	Adobe’s	site	and	see	a
handy	summary	of	features,	listed	by	the	year	they	were	released	(for	example,	Photoshop	CC	June	2014,	and	so	on).



Figure	1-8.	Most	of	the	built-in	workspaces	are	designed	to	help	you	perform	specialized	tasks.	For	example,	the
Photography	workspace	puts	the	Histogram	and	Navigation	panels	at	the	top	right.	Take	the	built-in	workspaces	for
a	test	drive	—	they’ll	undoubtedly	give	you	customization	ideas	you	hadn’t	thought	of!	If	you	don’t	see	the	Workspace
menu	and	you’ve	got	the	Application	Frame	turned	on,	point	your	cursor	at	the	right	side	of	the	Photoshop	window

and,	when	it	turns	into	a	double-headed	arrow,	click	and	drag	rightward	to	increase	the	frame’s	size.

To	save	your	own	custom	workspace,	first	open	and	arrange	the	panels	you	want	to
include.	Next,	click	the	Workspace	menu	and	choose	New	Workspace.	In	the	resulting
dialog	box,	give	your	setup	a	meaningful	name	and	turn	on	the	checkboxes	for	the
customizations	you	want	Photoshop	to	save.	In	addition	to	panel	locations,	you	can	save
any	keyboard	shortcut	and	menu	settings	you’ve	changed	(see	the	box	on	Customizing
Keyboard	Shortcuts	and	Menus	for	more	on	changing	these	items)	—	just	be	sure	to	turn
on	the	options	for	all	the	features	you	changed	or	they	won’t	be	included	in	your	custom
workspace.	When	you	click	Save,	your	workspace	shows	up	at	the	top	of	the	Workspace
menu.

If	you’ve	created	a	custom	workspace	that	you’ll	never	use	again,	you	can	send	it	packin’.
First,	make	sure	you	aren’t	currently	using	the	doomed	workspace.	Then,	from	the
Workspace	menu,	choose	Delete	Workspace	and,	in	the	resulting	dialog	box,	pick	the
offending	workspace	and	then	click	Delete.	Photoshop	will	ask	if	you’re	sure;	click	Yes	to
finish	it	off.

The	Tools	Panel
The	Tools	panel	(Figure	1-9,	left)	is	home	base	for	all	of	Photoshop’s	editing	tools,	and	it’s
included	in	all	the	built-in	workspaces.	Until	you	memorize	tools’	keyboard	shortcuts,	you
can’t	do	much	without	this	panel!	When	you	first	launch	the	program,	you’ll	see	the	Tools
panel	on	the	left	side	of	the	screen,	but	you	can	drag	it	anywhere	you	want	by	clicking	the
tiny	row	of	vertical	dashes	near	its	top	(Figure	1-9,	right).



Figure	1-9.	There’s	not	enough	room	in	the	Tools	panel	for	each	tool	to	have	its	own	spot,	so	related	tools	are
grouped	into	toolsets.	The	microscopic	triangle	at	the	bottom	right	of	each	toolset’s	button	lets	you	know	it	represents
more	than	one	tool	(the	Move	and	Zoom	tools	are	the	only	ones	that	live	alone).	To	see	the	other	tools,	click	the	tool’s
button	and	hold	down	your	mouse	button	(or	right-click	the	button	instead);	Photoshop	then	displays	a	list	of	the

other	tools	it	harbors	in	a	fly-out	menu,	as	shown	here	(left).	Photoshop	starts	you	off	with	a	one-column	Tools	panel
(left),	but	you	can	collapse	it	into	two	columns	(right)	by	clicking	the	tiny	double	triangles	circled	here	(click	’em

again	to	switch	back	to	one	column).	To	undock	the	Tools	panel,	grab	the	dotted	bar	labeled	here	and	drag	the	panel
wherever	you	want	it.	You	can	dock	the	Tools	panel	to	the	left	or	right	edge	of	your	screen,	or	leave	it	floating	free.

Once	you	expand	a	toolset	as	explained	in	Figure	1-9,	you’ll	see	the	tools’	keyboard
shortcuts	listed	to	the	right	of	their	names.	These	shortcuts	are	great	timesavers	because
they	let	you	switch	between	tools	without	moving	your	hands	off	the	keyboard.	To	access
a	tool	that’s	hidden	deep	within	a	toolset,	add	the	Shift	key	to	the	tool’s	shortcut	key,	and
you’ll	cycle	through	all	the	tools	in	that	toolset.	For	example,	to	activate	the	Elliptical
Marquee	tool,	press	Shift-M	repeatedly	until	that	tool’s	icon	appears	in	the	Tools	panel.

TIP

If	you	need	to	switch	tools	temporarily	—	for	a	quick	edit	—	you	can	use	the	spring-loaded	tools	feature.	Just	press
and	hold	a	tool’s	keyboard	shortcut	to	switch	to	that	tool,	and	then	perform	your	edit.	As	soon	as	you	release	the	key,
you’ll	jump	back	to	the	tool	you	were	using	before.	For	example,	if	you’re	painting	with	the	Brush	and	suddenly
make	an	error,	press	and	hold	E	to	switch	to	the	Eraser	and	fix	your	mistake.	Once	you	release	the	E	key,	you’re	back
to	using	the	Brush	tool.	Sweet!

You’ll	learn	about	the	superpowers	of	each	tool	throughout	this	book.	For	a	brief	overview
of	each	tool,	check	out	Appendix	C,	which	you	can	download	from	this	book’s	Missing
CD	page	at	www.missingmanuals.com/cds.

http://www.missingmanuals.com/cds


TIP

If	you	can’t	remember	which	tool	an	icon	represents,	point	your	cursor	at	the	icon	for	a	couple	of	seconds	while
keeping	your	mouse	perfectly	still.	After	a	second	or	two,	Photoshop	displays	a	handy	tooltip	that	includes	the	tool’s
name	and	keyboard	shortcut.

Foreground	and	Background	Color	Chips

Photoshop	can	handle	millions	of	colors,	but	its	tools	let	you	work	with	only	two	at	a	time:
a	foreground	color	and	a	background	color.	Each	of	these	is	visible	as	a	square	color	chip
near	the	bottom	of	the	Tools	panel	(labeled	in	Figure	1-9,	where	they’re	black	and	white,
respectively).	Photoshop	uses	your	foreground	color	when	you	paint	or	fill	something	with
color;	it’s	where	most	of	the	action	is.	The	program	uses	your	background	color	to	do
things	like	set	the	second	color	of	a	gradient	(a	smooth	transition	from	one	color	to
another,	or	to	transparency)	or	erase	parts	of	a	locked	Background	layer	(Restacking
Layers);	this	color	is	also	helpful	when	you’re	running	special	effects	like	the	Clouds	filter
(Pixelate).

To	change	either	color,	click	its	color	chip	once	to	open	the	Color	Picker	(Choosing
Individual	Colors),	which	lets	you	select	another	color	for	that	particular	chip.	To	swap
your	foreground	and	background	colors,	click	the	curved,	double-headed	arrow	just	above
the	two	chips	or	press	X.	To	set	both	color	chips	to	their	factory-fresh	setting	of	black	and
white,	click	the	tiny	chips	to	their	upper	left	(in	a	two-column	Tools	panel,	they’re	at	the
lower	left)	or	press	D.	Remember	those	two	keyboard	shortcuts	(X	and	D);	they’re
extremely	handy	when	you	work	with	layer	masks,	which	are	covered	in	Chapter	3.

Common	Panels
As	mentioned	earlier,	when	you	first	launch	Photoshop,	the	program	displays	the
Essentials	workspace,	which	includes	several	useful	panels.	Here’s	a	quick	rundown	of
why	Adobe	considers	these	panels	so	important:

Color.	This	panel	in	the	upper-right	part	of	your	screen	includes	your	current
foreground	and	background	color	chips	and,	from	the	factory,	a	trio	of	sliders	and	a
rainbow-colored	bar	that	you	can	use	to	pick	a	new	color	for	either	chip.	As	you’ll
learn	on	The	Color	Panel,	you	can	now	use	this	panel	as	a	color	picker	that’s	always
open!
Swatches.	This	panel	holds	miniature	color	samples,	giving	you	easy	access	to	them
for	use	in	painting	or	colorizing	images	(and	new	in	Photoshop	CC	2014,	the	most
recent	swatches	you’ve	used	show	up	in	a	handy	row	at	the	top	of	the	panel).	It	also
stores	a	variety	of	color	libraries	like	the	Pantone	Matching	System	(special	inks	used
in	professional	printing).	You’ll	learn	all	about	the	Swatches	panel	in	on	The	Swatches
Panel.
Adjustments.	This	panel	lets	you	create	adjustment	layers.	Instead	of	making	color
and	brightness	changes	to	your	original	image,	you	can	use	adjustment	layers	to	make
these	changes	on	a	separate	layer,	giving	you	all	kinds	of	editing	flexibility	and
keeping	your	original	image	out	of	harm’s	way.	They’re	explained	in	detail	in
Chapter	3,	and	you’ll	see	’em	used	throughout	this	book.
Styles.	Styles	are	special	effects	created	with	a	variety	of	layer	styles.	For	example,	if
you’ve	created	a	glass-button	look	by	adding	several	layer	styles	individually,	you	can



save	the	whole	lot	of	’em	as	a	single	style	so	you	can	apply	them	all	with	one	click.
You	can	also	choose	from	tons	of	built-in	styles;	they’re	discussed	starting	on	The
Styles	Panel.
Layers.	This	is	the	single	most	important	panel	in	Photoshop.	Layers	let	you	work	with
images	as	if	they	were	a	stack	of	transparencies,	so	you	can	create	one	image	from
many.	By	using	layers,	you	can	adjust	the	size	and	opacity	of	—	and	add	layer	styles	to
—	each	item	independently.	Understanding	layers	is	the	key	to	Photoshop	success	and
nondestructive	editing;	you’ll	learn	all	about	them	in	Chapter	3.
Channels.	Channels	are	where	Photoshop	stores	the	color	information	your	images	are
made	from.	Channels	are	extremely	powerful,	and	you	can	use	them	to	edit	the
individual	colors	in	an	image,	which	is	helpful	in	sharpening	images,	creating
selections	(telling	Photoshop	which	part	of	an	image	you	want	to	work	with),	and	so
on.	Chapter	5	has	the	scoop	on	channels.
Paths.	Paths	are	the	outlines	you	make	with	the	Pen	and	shape	tools.	But	these	aren’t
your	average,	run-of-the-mill	lines:	they’re	made	up	of	points	and	paths	instead	of
pixels,	so	they’ll	always	look	perfectly	crisp	when	printed.	You	can	also	resize	them
without	losing	any	quality.	You’ll	conquer	paths	in	Chapter	13.
History.	This	panel	is	like	your	very	own	time	machine:	It	tracks	nearly	everything
you	do	to	your	image	(the	last	50	things,	to	be	exact,	though	you	can	change	this
number	using	preferences	[see	Changing	How	Far	Back	You	Can	Go]).	It	appears
docked	as	a	button	to	the	left	of	the	Color	panel	group.	The	next	section	explains	how
to	use	it	to	undo	what	you’ve	recently	done	(if	only	that	worked	in	real	life!).
Properties.	This	panel,	which	is	also	docked	to	the	left	of	the	Color	panel	group,	is
where	you	access	the	settings	for	individual	adjustment	layers,	shape	layers,	linked
smart	objects,	and	layer	masks.	You’ll	dive	headfirst	into	masks	in	Chapter	3;	for	now,
think	of	them	as	digital	masking	tape	that	lets	you	hide	the	contents	of	a	layer.



The	Power	of	Undo
Thankfully,	Photoshop	is	extremely	forgiving:	It’ll	let	you	back	out	of	almost	anything
you	do,	which	is	muy	importante,	especially	when	you’re	getting	the	hang	of	things.

You’ve	got	several	ways	to	retrace	your	steps,	including	the	lifesaving	Undo	command.
Just	choose	Edit→Undo	or	press	⌘-Z	(Ctrl+Z).	This	command	lets	you	undo	the	very	last
edit	you	made.

If	you	need	to	go	back	more	than	one	step,	use	the	Step	Backward	command	instead:
Choose	Edit→Step	Backward	or	press	Option-⌘-Z	(Alt+Ctrl+Z).	Straight	from	the
factory,	this	command	lets	you	undo	the	last	50	things	you	did,	one	at	a	time.	If	you	want
to	go	back	even	further,	you	can	change	that	number	by	digging	into	Photoshop’s
preferences,	as	the	next	section	explains.	You	can	step	forward	through	your	editing
history,	too,	by	choosing	Edit→Step	Forward	or	Shift-⌘-Z	(Shift+Ctrl+Z).

NOTE

Photoshop	only	lets	you	undo	changes	back	to	the	point	when	you	first	opened	the	document	you’re	working	on,
meaning	you	can’t	close	a	document	and	then	undo	changes	you	made	before	you	closed	it.

Changing	How	Far	Back	You	Can	Go
If	you	think	you	might	someday	need	to	go	back	further	than	your	last	50	steps,	you	can
make	Photoshop	remember	up	to	1,000	steps	by	changing	the	program’s	preferences.
Here’s	how:

1.	 Choose	Photoshop→Preferences→Performance
(Edit→Preferences→Performance	on	a	PC).

2.	 In	the	Preferences	dialog	box’sHistory	States	field,	pick	the	number	of	steps	you
want	Photoshop	to	remember.
You	can	enter	any	number	between	1	and	1,000	in	this	field.	While	increasing	the
number	of	history	states	might	help	you	sleep	better,	doing	so	means	Photoshop	has
to	keep	track	of	that	many	more	versions	of	your	document,	which	requires	more
hard	drive	space	and	processing	power.	So	if	you	increase	this	setting	and	then
notice	that	the	program	is	running	like	molasses	—	or	you’re	suddenly	out	of	hard
drive	space	—	try	lowering	it.

3.	 Click	OK	when	you’re	finished.

Turning	Back	Time	with	the	History	Panel
Whereas	the	Undo	and	Step	Backward	commands	let	you	move	back	through	changes	one
at	a	time,	the	History	panel	(Figure	1-10)	kicks	it	up	a	notch	and	lets	you	jump	back
several	steps	at	once.	(You	can	step	back	through	as	many	history	states	as	you	set	in
Photoshop’s	preferences	—	see	the	previous	section.)	Using	the	History	panel	is	much
quicker	than	undoing	a	long	list	of	changes	one	by	one,	and	it	gives	you	a	nice	list	of
exactly	what	tools	and	menu	items	you	used	to	alter	the	image	—	in	chronological	order
from	top	to	bottom	—	letting	you	pinpoint	the	exact	state	you	want	to	jump	back	to.	And,
as	explained	in	a	moment,	you	can	also	take	snapshots	of	an	image	at	various	points	in	the
editing	process	to	make	it	easier	to	hop	back	to	the	state	you	want.

After	you	make	a	few	changes	to	an	image,	pop	open	the	History	panel	by	clicking	its


